Page 1 of 1

No sound from metronome

Posted: Tue Mar 07, 2017 4:20 pm
by TonyMountifield
I've just updated to 5.0 and enabled the metronome.

Unfortunately it doesn't make any sound. The twirler does its thing, and the bar goes across the top if enabled, but whatever I do with the volume control and mute switch, I get no sound.

Using iPad Pro 9.7 with iOS 9.3.5

Any ideas?

Tony

Re: No sound from metronome

Posted: Tue Mar 07, 2017 4:27 pm
by Phil Smith
We've tested this on devices(iPad 2, 4, Air, Pro 12.9) with iOS 8 to iOS 10.3 beta and no problem with the sound. Does your iPad make sounds otherwise?

Re: No sound from metronome

Posted: Tue Mar 07, 2017 4:51 pm
by TonyMountifield
Oh yes, no problem. From many other apps, including the metronome function in OnSong.

Have just restarted the iPad, just in case, and still the same. Volume turned up and other apps make sound.

Re: No sound from metronome

Posted: Tue Mar 07, 2017 6:00 pm
by Phil Smith
TonyMountifield wrote:Oh yes, no problem. From many other apps, including the metronome function in OnSong.

Have just restarted the iPad, just in case, and still the same. Volume turned up and other apps make sound.
Try taping the home key twice and swipe all apps up.

Re: No sound from metronome

Posted: Tue Mar 07, 2017 6:20 pm
by TonyMountifield
Was certainly worth a try, but still the same...

But then... I just remembered that in the iPad settIngs panel that swipes up from the bottom, I had the mute setting on. Turning it off allowed the iGigBook metronome sound to play.

The interesting thing is that all other apps still play their sound when mute is on. Normally mute just affects notification sounds. So I would think for consistency, iGigBook should also play its sound even when system mute is on. After all, it has its own mute switch in the app.

Re: No sound from metronome

Posted: Wed Mar 08, 2017 12:20 am
by Phil Smith
TonyMountifield wrote:Was certainly worth a try, but still the same...

But then... I just remembered that in the iPad settIngs panel that swipes up from the bottom, I had the mute setting on. Turning it off allowed the iGigBook metronome sound to play.

The interesting thing is that all other apps still play their sound when mute is on. Normally mute just affects notification sounds. So I would think for consistency, iGigBook should also play its sound even when system mute is on. After all, it has its own mute switch in the app.
According to Apple's documentation that mute button from the pull up Control Center should:
Quickly mute a song, movie, and more with a swipe and a tap
As far as the metronome in iGigBook is concerned, this would be the correct behavior despite what happens in other apps. The metronome shouldn't play it's sound when the system mute is on. The metronome mute switch as with all of the settings of the metronome can be assigned to an individual page which means on one page it can be on and on another page it can be off.

Re: No sound from metronome

Posted: Wed Mar 08, 2017 4:31 am
by TonyMountifield
That's interesting, because I always turn on mute when I go to bed, and often forget to turn it off again in the morning, sometimes for several days. Even when I have left mute on, I still get audio from Youtube, BBC videos, iReal, OnSong, Virtuoso Piano, and even Apple's own built-in music player (I've just checked). Anything, it would seem, where I've specifically requested the operation producing the sound.

The only sounds that system mute seems to affect (apart from iGigBook) are notification sounds from Mail, Twitter, Facebook, Word With Friends, Skype, and so on. So I assumed that was designed behaviour. Maybe the Apple documentation is no longer accurate (it does happen!).

Anyway, at least I know why, although it would be VERY nice, particularly in a gig setting, to be able to use the iGigBook metronome without also having to have system notification sounds un-muted. Hope you might consider this!

Thanks,
Tony