Page 1 of 1

Registering for Forum

Posted: Thu Dec 22, 2011 4:48 pm
by Boardwalk Jazzman
I'm a new user. First, I registered for my.igigbook.com from my iPad. No problem. Then, a couple days later, I tried to register for the forum. First I tried from the browser on my desktop Mac, and it wouldn't let me, saying my email address was already registered. I also tried to register from the iPad browser. That didn't work either. I then noticed it said that I had to do it from the app. But in my igigbook app there were only two buttons showing on the book list, so I couldn't do that either. Finally I gave up and registered for the forum by using an alternate email address. What step did I miss?

Re: Registering for Forum

Posted: Thu Dec 22, 2011 5:24 pm
by Phil Smith
If you registered from the app and can access my.igigbook.com, those credentials will also work here. Do you have access to my.igigbook.com?

Re: Registering for Forum

Posted: Fri Dec 23, 2011 3:39 pm
by Boardwalk Jazzman
I figured it out...when I registered from the iPad, I used my actual name as my name...when I tried to log into the forum for the first time, I supplied my email address in the user field...instead of my actual name. It's a very common habit. Then when that was rejected and it asked me to register, it asked me for my email address, which was rejected as already registered.

I would suggest you revise the registration process so there is one field for actual name and another field for your public, forum name. Most people don't want to use their real names on a public forum. But when you register a product most people use their real names to register.